03/08/2012

How to install OpenLayer plugin on a new QGIS 1.8 installation?


Bagaimana hendak memasang OpenLayer plugin pada QGIS 1.8 baru?

Selepas memberi latihan kepada beberapa staf mengenai QGIS dengan Win Ver. 1.7.4, salah seorang peserta jumpa saya pagi ini lengkap dengan notebook menyatakan kesukarannya memasang OpenLayers plugin pada Win QGIS Ver. 1.8. Pada mulanya, saya bingung tetapi kemudian sedar bahawa QGIS Ver 1.8 tidak mempunyai butang Update berbanding dengan QGIS Ver 1.7.4. Untuk mengatasinya, terdapat 2 opsyen:
  • Pasangkan QGIS Ver 1.7.4 seterusnya QGIS Ver 1.8 dan OpenLayer plugin akan papar (tentu lah dengan syarat ianya telah dimuat turun kat Plugins/Fetch Plygthon Plugins/Plugins).
  • Ambil kaedah lain dan pasang satu-demi-satu berpandukan Nama dan URL Repository yakni  kaedah ini perlu diambil untuk Ubuntu QGIS. Double-click imej kedua untuk mendapati URL  tapi untuk bagi QGIS anda, perlulah menggunakan Add button//enter name & URL/tick 'enabled'/OK. Untuk 'name', tak payah ikut sepenuhnya, contoh, taip 'sourcepole' dan bukan 'Sourcepole Repository' adalah memadai. Kedua, untuk alamat 'URL', taip 'build.sourcepole.ch/qgis/plugins.xml' adalah memadai kerana 'http://' dimasukkan automatik, seperti biasa alamat URL perlu ditaip dalam lower case. Selepas download siap, go to plugins tab/select plugin/install plugin.
Untuk rujukan module Table Manager teletak dibawah QGIS Contributed Repository (kalau tak salah). Kalau menghadapi masalah memasang QGIS Offical Reository 2, ini kemungkinan akibat QGIS Official Repository  menggunakan URL dari QGIS Offical Repository 2. Oleh itu, bagi QGIS Official Repository anda, ambil URL dari QGIS Official Repository 2 i.e. "http://pygis.org/repo/official dan semua akan beres. Yang penting, ianya berfungsi.

How to install OpenLayer plugin on a new QGIS 1.8 installation?

After training several staff on QGIS using the Win Ver. 1.7.4, one of them came back this morning with his notebook to inform that he had difficulty installing the OpenLayers plugin in the Win QGIS Ver. 1.8. I was baffled at first but soon realized that in QGIS Ver 1.8 the Update button does not appear unlike QGIS Ver 1.7.4. To overcome that, there are 2 options:
  • Install QGIS Ver 1.7.4 then QGIS Ver 1.8 and the OpenLayer plugin will appear (of course, on condition you selected it at Plugins/Fetch Python Plugins/Plugins).
  • Use the long shot and install one-by-one base on the Name and Repository URL which is the way it has to be done on an Ubuntu QGIS. Double-click the second image to look up the URL but for your QGIS, you need to use the Add button/enter name & URL/tick 'enabled'/OK. For the 'name', you do not really have to follow everything, for e.g. typing 'sourcepole' instead of 'Sourcepole Repository' is good enough. Secondly, for the 'URL' address, typing 'build.sourcepole.ch/qgis/plugins.xml' is good enough because the 'http://' is automatically added, as usual the URL address should be in lower case. After download completed, go to plugins tab/select plugin/install plugin.
For reference, the Table Manager module is located in the QGIS Contributed Repository (if not mistaken). If you found problem installing QGIS Official Repository 2, it could be because QGIS Official Repository took the URL belonging to QGIS Offical Repository 2. Thus, for your QGIS Official Repository, just take the URL from the QGIS Official Repository 2 i.e. "http://pyqgis.org/repo/official" and it'll work fine. The important thing is that it functions.

No comments:

Post a comment